Вы просматриваете автономную ( off-line ) версию сайта

СУХУМ 2006 : КАРТА ТУРИСТА

источник : http://vmlmapsh.narod.ru

версия : апрель 2006 г.

автор : myton@pochta.ru

Старт


SOUKHOUME 2006: INTERACTIVE TOURISTICAL MAP : MAIN PAGE

Сухум 2006 : главная

• О создании сайта.
• Когда это работает ?
• Как это работает ?
• Что в меню Загрузки
• Copyright
• Автор

О создании сайта : Цель создания сайта - общедоступная интерактивная туристическая карта Сухума . Среди множества электронных карт городов мира в Интернете, автор, к сожалению ,не встретил карту Сухума . Разумеется речь идет не о "растровых копиях " . Между прочим, некоторые туристические карты Сухума ,Абхазии времен СССР даже сегодня можно приобрести в сухумских книжных магазинах. Некоторые растровые копии подобных схем-карт Вы можете загрузить со страницы <<Загрузки>> данного сайта .
При создании электронной карты Сухума автором не ставилась задача точного воспроизведения конфигурации и расположения улиц. В первую очередь представляла интерес центральная часть города и 'быстро узнаваемые' каждым сухумчанином строения. Для многих старых улиц удалось подобрать соответствующие комментарии о возникновении, предыдущих названиях и т.д. Многие улицы 'сопровождаются' и графикой . К сожалению, для многих улиц в Н.Районе , Маяке, Турбазе автору пока не удалось дать подобного вида описаний. Тут открывается широкое поле деятельности для посетителей сайта, как в выявлении неизбежных ошибок , так и в возможных дополнениях .
Создание данного сайта явилось естественным развитием сайта автора : Абхазия в графических материалах , ( где доступно около 200 довольно редких фотографий по Абхазии нач . ХХ в. ), но в этот раз интерес был сосредоточен только на Сухуме .
При работе над " текстовым наполнением " cайта - использовались многочисленные консультации и обсуждения по старому Сухуму с А.С.Агумаа . Он же предоставил несколько "картинок" старого Сухума для данного сайта . Кроме того, А.С.Агумаа любезно предоставил автору сайта свою книгу "The architecture of Sukhum", exhibition catalogue [ Sukhum Soc. of Abkh. Hist. and Cult., 1999, 72p. ], материалы которой использовались для текстовых описаний улиц, строений.
Для иллюстраций электронной карты использовалось несколько фотографий современного Сухума ,любезно предоставленных В.В.Медведовским .
При создании сайта не использовалась финансовая поддержка каких-либо лиц, организаций. Создание сайта обусловлено исключительно интересами автора ( I.T.) к Сухуму, уроженцем которого он и является.

К началу страницы К началу страницы

Когда это работает : "Локализация" карты Сухума в отдельный сайт вызвана прежде всего тем, что при создании карты использовалась технология Microsoft ® Vector Markup Language (VML) , которая поддерживается только броузерами Microsoft Internet Explorer, начиная с 5 версии . Между прочим, VML поддерживает рисование , например, в MS WORD . Для Windows XP. физически библиотека расположена на C:\Program Files\Common Files\Microsoft Shared\VGX\vgx.dll
После полной загрузки страницы с картой ( либо с картинками, либо без них ) все операции по поиску, масштабированию, перетаскиванию , отображению информации будут выполняться на Вашем компьютере без запросов с сервера . Поэтому реальная скорость выполнения всех вышеуказанных операций с картой ( после полной загрузки страницы ) определяется только мощностью Вашего компьютера.
При тестировании страницы с картой в IE6 на компьютере с частотой процессора 433 МГц, все "интерактивные операции " выполняются с заметным "торможением". Для более "быстрого" компьютера с частотой процессора 1.4Ггц небольшое "торможение" проявляется лишь для режима отображения карты с градиентной заливкой - "Вид карты - Градиент" .

К началу страницы К началу страницы

Как это работает При загрузке страницы : Меню - карта Сухума , если Ваш броузер по крайней мере IE5 , у Вас на экране может появиться примерно следующее изображение .

Картинки
Страницу с картой "поддерживают" около 70 небольших картинок . Причем возможен режим просмотра страницы как с картинками, так и без них . Первоначально страница загружается без предзагрузки картинок. Кнопка в панели Картинки позволяет произвести предварительную загрузку картинок на Ваш компьютер. Именно ситуация когда картинки уже загружены в память показана на иллюстрации. Справа от кнопки предзагрузки картинок можно видеть общее число загруженных картинок - 62 и "объем загруженных картинок" в кВ . Конкретные значения этих величин в Вашем случае могут отличаться, т.к. при модернизации сайта картинки будут по-видимому добавляться .
До начала предзагрузки Вы можете просмотреть какие картинки имеются в базе данных страницы, выбрав в панели Поиск , фильтр -Все. При этом, в списке всех доступных объектов страницы, перед названием улиц, строений , для которых в БД имеется картинка , виден небольшой красный маркер . После загрузки соответствующей картинки цвет маркера изменится на зеленый - картинка доступна. Именно такие два маркера видны на иллюстрации в панели Поиск во 2 и 4 строках. В процессе предзагрузки 'доступность' картинок происходит динамически.
Вид карты
Панель Вид карты позволяет динамически менять способ рисования выводимого изображения. Однако, кроме чисто декоративных функций такой выбор не несет никакой информационной нагрузки. В режиме Вид карты - градиент , если ваш компьютер не " очень быстрый " , Вы по-видимому заметите небольшое торможение . особенно при движении курсора над картой . Так . при тестировании страницы в IE6 на машине с частотой процессора 1.4Ггц в режиме градиент наблюдалось небольшое торможение . Обладателям более медленных машин можно посоветовать использовать режим контраст .
Навигация
Панель навигация : кнопка [+ - ] , кнопка перетаскивание (рука) . В текущей версии страницы реализованы 2 масштаба просмотра карты. Переход между двумя масштабами реализуется одной кнопкой [+ -], которая меняет надпись в соответствии с текущим масштабом. Кнопка перетаскивания доступна при одном масштабе. При включенном режиме перетаскивания кнопка с изображением руки активируется зеленой окантовкой, а при наведении курсора на карту - курсор меняет вид .
Для перетаскивания карты : навести курсор в точку на карте, нажать левую кнопку мыши и сместить курсор в нужном направлении , после чего отпустить левую кнопку мыши .
Режим перетаскивания отключается при первом выходе курсора с карты .
Поиск
В базе данных ( БД ) , поддерживающей текущую версию карты , около 200 записей, примерно треть которых содержат соответствующие картинки . Поиск по БД доступен либо из динамической таблицы ( по клику ) в панели Поиск, либо непосредственно на карте . На карте объект активируется ( отображаются соответствующая подпись и картинка ), если Вы задержите курсор в определенной позиции минимум на 1.2 сек . Красные маркеры перед названием объекта в таблице означают, что в БД имеется соответствующая картинка, но она пока недоступна. После загрузки картинок цвет соответствующих маркеров меняется на зеленый.
Не для всех улиц на карте приведены соответствующие подписи. Однако, для всех улиц и объектов приведенных на карте, при активизации всплывающей подсказки можно получить соответствующую информацию .

К началу страницы К началу страницы

Что в меню загрузки : Если Вас заинтересовали материалы , представленные на сайте , Вы можете совершенно бесплатно скачать off-line ( автономную ) версию сайта со страницы Загрузки. Автономная версия сайта оформлена в виде файла .chm . Это один из стандартных форматов справочной системы Windows . Кроме того , со страницы Загрузки Вы можете скачать 'растровые' туристические карты Абхазии (1966 г. ) и Сухума (1989 г.) времен СССР , представлюяющие в значительной степени исторический интерес .

К началу страницы К началу страницы

Сopyright : Электронная карта Сухум 2006 : карта туриста является интеллектуальной собственностью автора сайта - И.Т. . Распространение ( в любом виде ) , любые изменения, дополнения электронной карты Сухум 2006 : карта туриста возможны только после письменного согласия автора сайта .

К началу страницы К началу страницы

Автор : По всем вопросам затронутым на страницах данного сайта Вы можете связаться с автором - И.Тоноян ; email : myton@pochta.ru

К началу страницы К началу страницы

Главная
Карта Сухума
Загрузки


SOUKHOUME 2006: INTERACTIVE TOURISTICAL MAP : DOWNLOADS

Сухум 2006 : Загрузки

Автономная ( Off-line ) версия данного сайта | Загрузить
Туристическая карта Сухума <<По черноморскому побережью Кавказа Сухуми - Сочи>> изд. ГУГИК 1989, М. | Загрузить 132 KB
Сухуми : Практический справочник туриста . Составители схемы: Г. Р. Чхартишвили, О. К. Македонский << АЛАШАРА>> Сухуми — 1966 | Загрузить 120 KB
Главная
Карта Сухума
Загрузки


SOUKHOUME 2006: INTERACTIVE TOURISTICAL MAP

СУХУМ 2006 : КАРТА ТУРИСТА
ЗАГРУЗКА СТРАНИЦЫ ...

SOUKHOUME 2006 : TOURISTICAL MAP
PAGE LOADING ...
Интерактивная карта Сухума загружена на Ваш компьютер !
Вид карты
Градиент
Заливка
Контраст
Навигация
Картинки
Загружено 0 из 100 (0k)
tablerow#1
Главная
Карта Сухума
Загрузки